0 Comments
The upgrade process is pretty simple but I had a few issues worth mentioning.

Issue 1
If you've upgraded to Sitecore 8.0 Initial, and try to hit the Content Editor before upgrading WFFMs too, you'll likely encounter an issue loading the Content Editor. Specifically, "
Could not load type 'Sitecore.Shell.Applications.WebEdit.Commands.WebEditCommand' from assembly 'Sitecore.Client, Version=7.0.0.0, Culture=neutral, PublicKeyToken=null'."

I couldn't find any reference to that class in /sitecore/admin/ShowConfig.aspx or the Core DB, and it seemed weird that the version was being reported as 7.0.0.0 when they should be 8.x. There wasn't much online, but the posts that did mention it talked of Sitecore 8 upgrades and WFFMs. Combined with the weird version being reported, I had a feeling I just needed to push forward and update WFFMs.

Sure enough, completing the install of the WFFMs .update package and updating the configs brought the Content Editor back to life.

Side note:
The Upgrade Guide doesn't mention it specifically as it probably assumes you're continuing after a Sitecore 8 upgrade, but if you're Forms configs aren't already disabled, do so before the package install to avoid another YSOD.

Issue 2
When following the Upgrade Guide, it means you may get some errors in the final report page. These will be in /sitecore/system/Modules/Web Forms for Marketers/Sample Forms/*. If you do, it mentions going through each of those (and I assume your own Form items) and making some manual corrections to the __Tracking field XML. But that's painful, so here's a gist of an ASHX that does this on load for you.